EvoReset 52a and new BaseConf

ZX evolution software and hardware

Postby CHRV » 13 Jan 2013, 08:04

Some old ROM not work with last baseconf and vice verse.
I recomend to use last ROM and baseconf.
If You found some errors than write here about it. Savelij will fix errors in ROM.
Presets stored in CMOS. If ZXEvo not store presets than may be battery is low or bad.
Многое есть здесь: www.nedopc.com
User avatar
CHRV
Желесяка
 
Posts: 923
Joined: 15 Apr 2007, 22:52
Group: Registered users

Postby ra9abz » 17 Jan 2013, 17:58

Всех с Новым годом!
Перепрошил свой Zxevo теми файлами, которые выложены на сайте.
- С часами та же ерунда. Похоже они останавливаются на время запуска программ.
- Звук пропал, beep в бейсике не работает.
До этого стоял EVO reset 0.37.
Пробовал перепрошивать обратно, часы пошли нормально, только не читались SD и HDD т.к. стоял AVR boot 23 01 2012.
Запускал с ГМД. Часы не останавливались и звук был.
Прошил обратно SD и Hdd заработали, часы стали отставать и звук пропал.
- Если можно ещё прошивку с неизменённым BASIC 48 а то опять Song in lines перестала работать.
Работает на LED мониторе AOC e2450Swda. Пришлось немного подобрать кварц 9319.44КГцх3.125 (и с дискет читает), плата rev.B
P/S Кварц можно бы и круглый какой, если-бы в альтере коэффициент деления для ВГ-шки поменять, с учётом чтоб на монитор шло 56Гц.
ZX evolution rev B
User avatar
ra9abz
 
Posts: 33
Joined: 14 Jan 2011, 22:38
Location: Челябинск
Group: Registered users

Postby lvd » 17 Jan 2013, 18:39

ra9abz wrote:- Если можно ещё прошивку с неизменённым BASIC 48 а то опять Song in lines перестала работать.

Так вроде ж оно и будет, если выбрать в ево-меню GLUK и нажать ресет.
Многого нет здесь: http://lvd.nedopc.com
Image
User avatar
lvd
 
Posts: 1637
Joined: 07 Apr 2007, 22:28
Group: Registered users

Postby CHRV » 17 Jan 2013, 18:52

ra9abz wrote:- Звук пропал, beep в бейсике не работает.

Доку почитай: http://www.nedopc.com/zxevo/zxevo_user_manual_revc.pdf
Особенно последнюю страницу и назначение клавиши NumLock.
ra9abz wrote: с учётом чтоб на монитор шло 56Гц.

Я даже не знаю что и сказать :) Эмулятор вроде может так.

P.S. ПРОШИВАТЬ НАДО ОБА ФАЙЛА baseconf и ROM иначе там вообще может ничего не работать.
Многое есть здесь: www.nedopc.com
User avatar
CHRV
Желесяка
 
Posts: 923
Joined: 15 Apr 2007, 22:52
Group: Registered users

Postby lvd » 17 Jan 2013, 19:00

ra9abz wrote:P/S Кварц можно бы и круглый какой, если-бы в альтере коэффициент деления для ВГ-шки поменять, с учётом чтоб на монитор шло 56Гц.

а если не поменять, и тупо при коэффициенте PLL в 4 (как раньше) влепить 8МГц кварц? 56/48.8 = 1.15 ~ 8/7
А дисковод проверить, заработает ли, а то вдруг заработает :-D
Многого нет здесь: http://lvd.nedopc.com
Image
User avatar
lvd
 
Posts: 1637
Joined: 07 Apr 2007, 22:28
Group: Registered users

Postby ra9abz » 18 Jan 2013, 19:27

Со звуком виноват, так оно.
song in lines скачал отсюда http://anime4ok.narod.ru/ZX-DOS/ZX-DOS.HTM работает при разлоченной памяти.
кварц ставил на 9.6 соотношение 1.07 - конец дискеты плохо читает, 9.319 -> 1.04 всё читается, <1.15

Батарейку поменял однако, но часы нормально так и не ходют.
07:07:00 ... 07:07:23 нажимаю F12 или кнопку reset 07:07:00 - секунды сбрасываются.
вот и получается что отстают.
ZX evolution rev B
User avatar
ra9abz
 
Posts: 33
Joined: 14 Jan 2011, 22:38
Location: Челябинск
Group: Registered users

Postby CHRV » 19 Jan 2013, 05:41

ra9abz wrote:Батарейку поменял однако, но часы нормально так и не ходют.
07:07:00 ... 07:07:23 нажимаю F12 или кнопку reset 07:07:00 - секунды сбрасываются.
вот и получается что отстают.

Войди в окно редактирования CMOS и посмотри как себя ведут ячейки, каких нить случайных изменений нет?
Если есть то замкни на плате R29 (под разъемом X5 и слева от ATMEGA)
Многое есть здесь: www.nedopc.com
User avatar
CHRV
Желесяка
 
Posts: 923
Joined: 15 Apr 2007, 22:52
Group: Registered users

Postby ra9abz » 19 Jan 2013, 15:12

Просто так "на глазах" ячейки не изменяются, 2 последние изменяются с 00 на 2D 2B после выхода и входа снова (резистор закоротил), там ещё есть 10к на землю, его пока не отрывал.
Это надо плату из корпуса вытаскивать.
Пробовал возвратиться к старой прошивке 037, 033 - не читаются файлы на SD и HDD. может надо было стереть атмегу перед записью (хотя в батнике вроде стирание есть).
Переписал обратно на 052а, перед этим сначала стёр Atmega.
всё равно пока секунды так и сбрасываются. При старой прошивке этого не наблюдалось. (может Atmega глючит ?) а так гонял разные демки, вроде работают.
ZX evolution rev B
User avatar
ra9abz
 
Posts: 33
Joined: 14 Jan 2011, 22:38
Location: Челябинск
Group: Registered users

Postby baxter » 19 Jan 2013, 16:31

У меня с секундами та же хрень.
ZX Evo rev b evoreset 0.55d
User avatar
baxter
 
Posts: 111
Joined: 15 Mar 2011, 21:11
Location: Ростов-на-Дону
Group: Registered users

Postby CHRV » 19 Jan 2013, 19:15

Проверил, под отладочной версией. При инициализации пишется зачемто в нулевую ячейку кмоса 0 - что и сбрасывает секунды.
Дядя Слава - лови багу.
Многое есть здесь: www.nedopc.com
User avatar
CHRV
Желесяка
 
Posts: 923
Joined: 15 Apr 2007, 22:52
Group: Registered users

PreviousNext

Return to Пентева - софт и железо

Who is online

Users browsing this forum: No registered users and 4 guests

cron