Нужна помощь в отладке ZXEvo rev B.

ZX evolution software and hardware

Postby FLYNC » 31 Mar 2014, 13:57

Привет всем. Во общем давно у меня валялась плата ZXEvo rev B. так как я при пайке плис запорол две ножки, и вот мне починили эти две ножки, напаял остальное, подключил БП ATX. Но блок не запустился, нужна помощь, кто может помочь в оживлении и настройке ? Территориально м. Красногвардейская.
FLYNC
 
Posts: 11
Joined: 30 Mar 2014, 14:22
Group: Registered users

Postby CHRV » 31 Mar 2014, 17:30

Прошивку туда залили?
И вообще читали вот это: http://www.nedopc.com/zxevo/zxevo_solde ... t_revb.pdf
Многое есть здесь: www.nedopc.com
User avatar
CHRV
Желесяка
 
Posts: 923
Joined: 15 Apr 2007, 22:52
Group: Registered users

Postby FLYNC » 31 Mar 2014, 20:40

Это я читал, но не совсем понял, програматором сначала заливаю бутлоадер. Но не понятно должен ли быть подключен при этом АТХ БП или нет, и когда запустится АТХ БП. или после заливки бутлоадера бп запустится ?
FLYNC
 
Posts: 11
Joined: 30 Mar 2014, 14:22
Group: Registered users

Postby CHRV » 31 Mar 2014, 22:56

FLYNC wrote:Это я читал, но не совсем понял, програматором сначала заливаю бутлоадер. Но не понятно должен ли быть подключен при этом АТХ БП или нет, и когда запустится АТХ БП. или после заливки бутлоадера бп запустится ?

1) У АТХ БП есть standby нпаряжение, и если БП подключено к розетке то прошивка должна заливаться.
2) Я обычно заливаю бутлоадер совмещенный c TEST&SERVICE, при этом плата запускается.
http://www.nedopc.com/zxevo/rom/bootloader20120124.zip
Многое есть здесь: www.nedopc.com
User avatar
CHRV
Желесяка
 
Posts: 923
Joined: 15 Apr 2007, 22:52
Group: Registered users

Postby FLYNC » 01 Apr 2014, 09:50

Спасибо, вечером попробую залить :)
FLYNC
 
Posts: 11
Joined: 30 Mar 2014, 14:22
Group: Registered users

Postby FLYNC » 07 Apr 2014, 21:15

Вообщем пока не получается прошить :( вот что выдает :
D:\progg>avrdude -F -q -C avrdude.conf -p m128 -c avrisp -P COM3 -b 19200 -e -U flash:w:zxevo_bl.hex
avrdude: stk500_getsync(): not in sync: resp=0x00
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

avrdude done. Thank you.
FLYNC
 
Posts: 11
Joined: 30 Mar 2014, 14:22
Group: Registered users


Return to Пентева - софт и железо

Who is online

Users browsing this forum: XRumerTest and 5 guests

cron