Глюки работы с CMOS-RTC

ZX evolution software and hardware

Postby breeze » 02 Feb 2011, 01:15

lvd wrote:Сколько вольт на батарейке, когда её меняют в очередной раз? И когда она в пентеве установлена.


ну как дойдут руки, замерю ещё раз
User avatar
breeze
 
Posts: 762
Joined: 07 Feb 2009, 17:19
Location: Оттуда
Group: Registered users

Postby CHRV » 02 Feb 2011, 12:18

kgbond wrote:Роман, с удовольствием заехал бы и погулял бы по Москве, но я в Питере и пока, ни как, т.к. на носу HB2U. Но зато выяснилась некоторая определенность в сбоях по времени и установках Virtual Drive - открыл настройки CMOS (F12+S) и обнаружил, что где-то через 1 минуту работы компа в CMOSе сыпется какой-то мусор. Во всех ячейках проскакивает символ копирайта - естественно сбиваются часы и другие переменные. Похоже что-то с шинами SDA, SCL.

Давай я тебе сделаю тестовую версию, работающую на пониженной частоте с интерфейсом микросхемы часов, может в этом дело...
Хотя сделано согласно даташиту.

СОбственно вот она (понизил частоту в два раза):
zxevo_fw.zip
(35.01 KB) Downloaded 142 times
Многое есть здесь: www.nedopc.com
User avatar
CHRV
Желесяка
 
Posts: 923
Joined: 15 Apr 2007, 22:52
Group: Registered users

Postby lvd » 02 Feb 2011, 13:56

CHRV wrote:Давай я тебе сделаю тестовую версию, работающую на пониженной частоте с интерфейсом микросхемы часов, может в этом дело... Хотя сделано согласно даташиту.

А разве у тебя вся инфа не кешируется в озу? Ведь глюки не сразу, а через время.
Многого нет здесь: http://lvd.nedopc.com
Image
User avatar
lvd
 
Posts: 1682
Joined: 07 Apr 2007, 22:28
Group: Registered users

Postby CHRV » 02 Feb 2011, 14:05

lvd wrote:А разве у тебя вся инфа не кешируется в озу? Ведь глюки не сразу, а через время.

Кэшируются токо 14 регистров, часы + управляющие.
Многое есть здесь: www.nedopc.com
User avatar
CHRV
Желесяка
 
Posts: 923
Joined: 15 Apr 2007, 22:52
Group: Registered users

Postby kgbond » 02 Feb 2011, 22:56

Ок! Спасибо, попробую. О результатах отпишусь.
kgbond
 
Posts: 30
Joined: 19 Dec 2010, 16:13
Location: СПб
Group: Registered users

Postby kgbond » 02 Feb 2011, 23:28

Не помогло, примерно через 1 минуту, CMOS посыпался! :'( Видео CMOS прикладываю.
Attachments

MVI_4565.avi [ 952.93 KB | Viewed 4009 times ]

kgbond
 
Posts: 30
Joined: 19 Dec 2010, 16:13
Location: СПб
Group: Registered users

Postby lvd » 02 Feb 2011, 23:49

kgbond wrote:Не помогло, примерно через 1 минуту, CMOS посыпался! :'( Видео CMOS прикладываю.

Напряжение на батарейке при этом какое?
Оба ли диода на питание часиков исправны?
Многого нет здесь: http://lvd.nedopc.com
Image
User avatar
lvd
 
Posts: 1682
Joined: 07 Apr 2007, 22:28
Group: Registered users

Postby kgbond » 03 Feb 2011, 00:37

На батарее под нагрузкой 3,02В (анод VD5). Диоды исправны. Без питания на 8 ноге D15 относительно 4 - 2,65В, при подаче питания 4,32В. На аноде VD4 4,73В - это нормально, т.к. пропущено через VD2.
kgbond
 
Posts: 30
Joined: 19 Dec 2010, 16:13
Location: СПб
Group: Registered users

Postby CHRV » 04 Feb 2011, 11:52

kgbond wrote:Не помогло, примерно через 1 минуту, CMOS посыпался! Видео CMOS прикладываю.

Ну тогд кроме замены PCF8583 ничего в голову не приходит.
Многое есть здесь: www.nedopc.com
User avatar
CHRV
Желесяка
 
Posts: 923
Joined: 15 Apr 2007, 22:52
Group: Registered users

Postby kgbond » 08 Feb 2011, 15:14

Поменял, PCF8583 ни чего не изменилось. :'( Пока менял запустил машину без PCF8583 и обнаружил при просмотре CMOS (F12+S) те же проблемы – проскакивание левых кодов, но зато постоянно включен режим «Турбо», «Virtual Drive:A» и отсутствует окошко с часами - так и должно быть. Может быть придется менять Atmega128, похоже что-то с шиной SDA, читается с нее какой-то левак даже без PCF8583, хотя она постоянно в 1. Более досконально погляжу осцилом и отпишусь.
kgbond
 
Posts: 30
Joined: 19 Dec 2010, 16:13
Location: СПб
Group: Registered users

PreviousNext

Return to Пентева - софт и железо

Who is online

Users browsing this forum: ValeriySyday and 4 guests

cron