Сlock

ZX evolution software and hardware

Postby DimkaM » 30 Sep 2011, 09:28

Как грамотно юзать регистр 0х0В?
Сейчас, что бы активировать hex формат, пишу в него 0х06.
Оно конечно работает, но может сначала прочитать регистр выставить бит и записать обратно?

И вертать взад бит обязательно или он ресетится при ресете?
Last edited by DimkaM on 30 Sep 2011, 09:36, edited 1 time in total.
ZX-Evo rev C, ZXNetUsb rev С
DimkaM
 
Posts: 1290
Joined: 24 Mar 2010, 13:42
Location: джунгли Амазонки
Group: Registered users

Postby savelij » 30 Sep 2011, 09:34

А ты думал что в сказке живешь? Именно читешь байт, меняешь бит и записываешь обратно. Без вариантов. Просто запись в туда ламеризм.
savelij
 
Posts: 520
Joined: 10 Jun 2008, 17:35
Group: Registered users

Postby DimkaM » 30 Sep 2011, 09:38

Ок, спасибки.
ZX-Evo rev C, ZXNetUsb rev С
DimkaM
 
Posts: 1290
Joined: 24 Mar 2010, 13:42
Location: джунгли Амазонки
Group: Registered users

Postby DimkaM » 20 Oct 2011, 12:01

Я у себя такого не замечал,бывает пару-тройку недель не включаю, но тикают точно.
ZX-Evo rev C, ZXNetUsb rev С
DimkaM
 
Posts: 1290
Joined: 24 Mar 2010, 13:42
Location: джунгли Амазонки
Group: Registered users

Postby lvd » 20 Oct 2011, 12:33

надо подсроечник и крутить его.
Многого нет здесь: http://lvd.nedopc.com
Image
User avatar
lvd
 
Posts: 1637
Joined: 07 Apr 2007, 22:28
Group: Registered users

Postby нолька » 20 Oct 2011, 15:44

надо апдейтить через сервак
я проснулся среди ночи и понял, что всё...
всё идет по плану
User avatar
нолька
рОвный
 
Posts: 264
Joined: 08 Apr 2007, 21:12
Group: Registered users

Postby Byteman » 20 Oct 2011, 23:23

Всем привет!

Восстанавливаю добитую пентеву, и возникла проблема с часиками... Я проблему описывал на zxpkru, но там внятного ответа не добился, посему решил спросить на официальном форуме поддержки.
Проблема вот в чём. Не заводится кварц на RTC. Какие значения записал в CMOS в регистры часов, минут и секунд - эти значения и читаются, т.е. часы не тикают, хотя настройки хранят как надо. При включении, сбросе, редактировании настроек CMOS есть активность на SPI-шине между часами и атмегой. На первом контакте часов - уровень чуть выше нуля, на втором - +5В. Соплей в том узле нет, замыканий тоже.... Вот думаю - мож внешний генератор сделать и частоту напрямую на RTC подать?
Last edited by Byteman on 21 Oct 2011, 12:39, edited 1 time in total.
С уважением, Александр.
ZX-Evolution Reb.B RIP :(
SID-Blaster/ZX - coming soon.....
Byteman
 
Posts: 39
Joined: 18 Oct 2011, 13:28
Location: Беларусь, Брест/Минск
Group: Registered users

Postby lvd » 21 Oct 2011, 14:59

проверь что кварц живой, что кондёр при кварце живой (лучше всего методом замены), что мсх живая по части кварцегенерения. Если не хватает кондёра, то ткнувшись осциллоглядом и получив генерацию, меняй кондёр. Ещё может быть засрана плата говнофлюсом с дикой проводимостью и шунтирует высокоомный генератор.
Многого нет здесь: http://lvd.nedopc.com
Image
User avatar
lvd
 
Posts: 1637
Joined: 07 Apr 2007, 22:28
Group: Registered users

Postby Byteman » 02 Nov 2011, 13:53

Вобщем, часы поборол достаточно просто. Отпаял микросхему, промыл там всё, запаял обратно - PROFIT!!!! :)
С уважением, Александр.
ZX-Evolution Reb.B RIP :(
SID-Blaster/ZX - coming soon.....
Byteman
 
Posts: 39
Joined: 18 Oct 2011, 13:28
Location: Беларусь, Брест/Минск
Group: Registered users

Postby lvd » 02 Nov 2011, 14:13

хаха, я говорил что все флюсы гогно кроме койнефоле -- вот подтверждение :)
Многого нет здесь: http://lvd.nedopc.com
Image
User avatar
lvd
 
Posts: 1637
Joined: 07 Apr 2007, 22:28
Group: Registered users

Next

Return to Пентева - софт и железо

Who is online

Users browsing this forum: Spoadikfes and 5 guests

cron