не работает AY-3-8910

ZX evolution software and hardware

Postby zorel » 18 Mar 2012, 17:11

Заведомо рабочая AY-3-8910, на zx evo rev.c не работает, почему-то. Может гдето джампер какой нибудь нужно установить что-бы заработало?
zorel
 
Posts: 58
Joined: 06 Oct 2011, 07:55
Group: Registered users

Postby CHRV » 18 Mar 2012, 17:17

Традиционно:
1) Какая прошивка
2) Какая скорость
3) Какая модель памяти
4) Какая программа
Многое есть здесь: www.nedopc.com
User avatar
CHRV
Желесяка
 
Posts: 923
Joined: 15 Apr 2007, 22:52
Group: Registered users

Postby zorel » 18 Mar 2012, 17:20

на любой скорости, прошивка последняя, та что доступна для закачки от сюда. http://www.nedopc.com/zxevo/zxevo.php
Я так понял, память, линейки Озу имелось в виду? Запаяны OKI M5118160F-60J 2 шт из комплекта для сборки.
zorel
 
Posts: 58
Joined: 06 Oct 2011, 07:55
Group: Registered users

Postby zorel » 18 Mar 2012, 17:24

Звука нет даже в меню при перезагрузке эвы.

с ямахой работает как надо.
zorel
 
Posts: 58
Joined: 06 Oct 2011, 07:55
Group: Registered users

Postby CHRV » 18 Mar 2012, 21:09

У меня на этой прошивке работают и АУ38910 и АУ38912 что я неправильно делаю?
ТАк и не увидел:
- модель памяти (48/128/ALL)
- скорость (3.5/7/14)
- программа в которой проверяется АУ
Многое есть здесь: www.nedopc.com
User avatar
CHRV
Желесяка
 
Posts: 923
Joined: 15 Apr 2007, 22:52
Group: Registered users

Postby zorel » 19 Mar 2012, 15:06

пробовал на разных параметрах.
Память выставлял любую 48/128/ALL
Скорость также пробовал разную 3.5/7/14

правда чипы у меня 1 83 года, 2-й 87-го может из-за этого не работать?
Пробовал после тестов AYшки на других клонах, работает..

Демо:AAACOMP1
Да и в меню не звуков.
Attachments
AAACOMP1.TRD
(640 KB) Downloaded 263 times
zorel
 
Posts: 58
Joined: 06 Oct 2011, 07:55
Group: Registered users

Postby нолька » 19 Mar 2012, 16:33

тесты чип AY видят?
я проснулся среди ночи и понял, что всё...
всё идет по плану
User avatar
нолька
рОвный
 
Posts: 264
Joined: 08 Apr 2007, 21:12
Group: Registered users

Postby CHRV » 19 Mar 2012, 19:35

Попробовал на демке SPAZM (на 3.5 и на 14мгц) следующие чипы:
1) AY38912 87года выпуска - все работает
2) AY38912 09года выпуска - все работает
3) AY38910 08года выпуска - все работает
4) WF19054 (хз какого года) - все работает

Имхо баго в железе: посмотри доходят ли все управляющие сигналы до AYков.
Многое есть здесь: www.nedopc.com
User avatar
CHRV
Желесяка
 
Posts: 923
Joined: 15 Apr 2007, 22:52
Group: Registered users

Postby zorel » 19 Mar 2012, 21:26

Да, сигналы доходят, должен работать, только не работает, да AYшкуи проверял на 2х zx evo одинаково. Да и еще тестировал в бейсике на ямахе, у меня почему-то не работает пищалка бипер в бейсике 48.
Last edited by zorel on 19 Mar 2012, 22:18, edited 6 times in total.
zorel
 
Posts: 58
Joined: 06 Oct 2011, 07:55
Group: Registered users

Postby CHRV » 19 Mar 2012, 21:33

zorel wrote:Да, сигналы доходят, должен работать, только не работает, да AYшкуи проверял на 2х zx evo одинаково. Да и еще тестировал в бейсике на ямахе, не работает бипер.

У меня версий больше нет, попробуй версию прошивки взять из SVN (самую последнюю).
На своих ZXEVo добиться нерабочести никак не получается.
Многое есть здесь: www.nedopc.com
User avatar
CHRV
Желесяка
 
Posts: 923
Joined: 15 Apr 2007, 22:52
Group: Registered users

Next

Return to Пентева - софт и железо

Who is online

Users browsing this forum: No registered users and 7 guests

cron