Не работает Soft reset

ZX evolution software and hardware

Postby petrov1962 » 26 Jul 2019, 18:31

Не работает кнопка Soft reset... ZX Evo rev.C
Почитал форум, у кого-то не работал VD2, заменил, также заменил VT3, безрезультатно...
А без этого прошивку атмеги не обновить. Программатора нет, да и боюсь что-либо не то залить в атмегу.
Подскажите, может кто сталкивался с подобной ситуацией?
Мои познания в схемотехнике заканчиваются следованием чужих советов.
petrov1962
 
Posts: 5
Joined: 30 Nov 2018, 17:03
Group: Registered users

Postby lvd » 26 Jul 2019, 22:10

А если замыкать контакты прям на плате, тоже не работает?
Многого нет здесь: http://lvd.nedopc.com
Image
User avatar
lvd
 
Posts: 1682
Joined: 07 Apr 2007, 22:28
Group: Registered users

Postby petrov1962 » 27 Jul 2019, 12:03

Если замыкать на плате - тоже не работает...
petrov1962
 
Posts: 5
Joined: 30 Nov 2018, 17:03
Group: Registered users

Postby lvd » 31 Jul 2019, 12:12

Контакт soft resetа звонится до соотв. пина атмеги?
Многого нет здесь: http://lvd.nedopc.com
Image
User avatar
lvd
 
Posts: 1682
Joined: 07 Apr 2007, 22:28
Group: Registered users

Postby petrov1962 » 26 Sep 2019, 21:39

Перепаял транзисторы, софт резки заработал, умудрился устроить КЗ на 5 в.... Атмега не грузится... Поменял атмегу - просадка по питанию на Альтере... Поменял Альтеру, получил вот такое. Куда копать? Все дорожки под микроскопом просмотрены, вроде нормально припаяны.
Attachments
1569513990.3169993133.err.gif
(37.83 KB) Not downloaded yet
petrov1962
 
Posts: 5
Joined: 30 Nov 2018, 17:03
Group: Registered users

Postby lvd » 27 Sep 2019, 19:46

Проверять всё, связанное с ФПГА: напряжения, сигналы, сам чип и етц.

По опыту, если устроить кз питания на землю на запитанной плате, могут вылететь все соседние и не очень КМОП-микросхемы (т.е. для ZX-evo -- вообще все).
Симптомы -- начинается дикий ужор тока и сильный разогрев, на фоне этого могут быть попытки как-то работать. В общем для начала можно общупать пальцем все мсх и стабилизаторы 3.3в и 2.5в при плате под напряжением, ну и напряжения из этих стабилизаторов тоже измерить.
Многого нет здесь: http://lvd.nedopc.com
Image
User avatar
lvd
 
Posts: 1682
Joined: 07 Apr 2007, 22:28
Group: Registered users

Postby petrov1962 » 28 Sep 2019, 18:28

Проверили управляющие сигналы с контроллера

config
status
confdone

поднимаются и опускаются, не в 0 или 1 все время

сигналы данных на fpga

`spics
spick
spido
spidi

тоже все доходят и по ним видно идет обмен данными

как проверяется целостность проишивки fpga, что дополнительно проверяется ? также насколько влияет тактовый генератор на микросхеме D21 похоже она умерла на прошивку fpga ?
Все напряжения в норме.
petrov1962
 
Posts: 5
Joined: 30 Nov 2018, 17:03
Group: Registered users

Postby lvd » 29 Sep 2019, 01:47

Целостность как-то проверяется самой фпга, если confdone встаёт то она думает что в нее влили всё ок.
Клоки на фпга для заливки прошивки никакие не нужны. Пока прошивка не влита вообще все пины не сконфигурены даже.

На что именно ругается T&S я не очень в курсе, можно спросить у автора (DDp) или посмотреть в код.
Многого нет здесь: http://lvd.nedopc.com
Image
User avatar
lvd
 
Posts: 1682
Joined: 07 Apr 2007, 22:28
Group: Registered users

Postby lvd » 29 Sep 2019, 01:48

Кстати как вариант, поменять sd-карту и повторить влив T&S и далее. Она могла тоже отхватить при КЗ.
Многого нет здесь: http://lvd.nedopc.com
Image
User avatar
lvd
 
Posts: 1682
Joined: 07 Apr 2007, 22:28
Group: Registered users


Return to Пентева - софт и железо

Who is online

Users browsing this forum: No registered users and 5 guests

cron