Работа с RAM диском из TR-DOS

ZX evolution software and hardware

Postby shafonya » 16 Aug 2019, 19:50

ZX Evolution Rev. C
EVO Reset Service 0.58.09
Baseconf: ZXEvo 4M 25.05.2019 beta
AVR Boot: ZXEvoAVRBoot 23.01.2012

К эве подключено два физических дисковода:
Дисковод А - 5.25''
Дисковод B - 3.5''

Хочу в TR-DOS скопировать файл из scl образа на физический диск.
Монтирую scl образ на ramdisk. Выставляю Virtual Drive - D.
TR-DOS Drive стоит A.
Запускаю TR-DOS клавишей S, перехожу на диск D (*"D"), TR-DOS пишет No disk.

Но если TR-DOS drive выставить D - то есть ту же букву, что и у рамдиска, то TR-DOS нормально отобразит содержимое рамдиска. Но при этом если я перехожу на любой другой дисковод, отличный от D, то физически обращения к нему не происходит, а команда LIST выдаёт список файлов с рамдиска.
shafonya
 
Posts: 8
Joined: 13 Aug 2019, 12:09
Group: Registered users

Postby savelij » 16 Aug 2019, 20:52

Обновись. Текущая версия 0.58.13 Возможно проблема уже устранена. Если нет пишите.
savelij
 
Posts: 549
Joined: 10 Jun 2008, 17:35
Group: Registered users

Postby shafonya » 16 Aug 2019, 22:52

Обновился. (Обновил только EVO Reset Service)
Описанная выше проблема ушла.

Но появилась другая.
Монтирую образ на рамдиск, захожу в TR-DOS
Копирую все файлы с рамдиска на физический (COPY "A:*","D:*"). Копирование проходит успешно. На дискете файлы на месте.
Пытаюсь запустить boot с дискеты - вылетает в бейсик или зависает. При этом с рамдиска все запускается.
Одинаковое поведение и для 5.25 и для 3.5 дисковода. Дискеты пробовал форматил и ADS и TR-DOSовой форматилкой. Пробовал разные дискеты. НИ на одной из опрбованных не было битых секторов.

То же самое получаю, когда копирую файлы из TRD образа, смонтированного на C. (То есть не с рамдиска)

В версии Evo Reset Service 0.58.09 такое поведение было только когда я пробовал использовать WDC для разворачивания trd на физический диск. При копировании файлов из смонтированных trd через TR-DOS все работало хорошо.

Ещё заметил после обновления, что при запуске TR-DOS, перестал автоматически запускаться boot файл. И при переключении текущего дисковода, например, *"A" на нём не загорается лампочка. (Раньше загоралась)
shafonya
 
Posts: 8
Joined: 13 Aug 2019, 12:09
Group: Registered users

Postby savelij » 17 Aug 2019, 13:53

Проверю вечером. А автоматический запуск бута это при сбросе из ерс в еводос?
savelij
 
Posts: 549
Joined: 10 Jun 2008, 17:35
Group: Registered users

Postby shafonya » 17 Aug 2019, 14:23

savelij wrote:А автоматический запуск бута это при сбросе из ерс в еводос?

Да.
Выставляю TR-DOS Drive A. (В дисководе вставлена непустая дискета)
Запускаю TR-DOS клавишей S.
shafonya
 
Posts: 8
Joined: 13 Aug 2019, 12:09
Group: Registered users

Postby savelij » 18 Aug 2019, 21:05

В общем на реале проверить не могу. Проверил только под эмулем. Автозапуск работает. Копирование тоже проблем нет. Пока даже не знаю что искать.
savelij
 
Posts: 549
Joined: 10 Jun 2008, 17:35
Group: Registered users

Postby shafonya » 24 Aug 2019, 01:50

С обращением к физическим дисководам нашел закономерность.
При запуске TR-DOS или при переключении на другой дисковод внутри TR-DOS, к нему не происходит обращения в 2х случаях:
1. Рамдиск выставлен как D (не важно, пустой или нет)
2. На D смонтирован TRD образ.
Выставляем рамдиск на C, отмонтируем D. Автозапуск работает.
Снова ставим рамдиск D или понтируем на D TRD образ - автозапуск перестает работать.
Повторяется стабильно.
shafonya
 
Posts: 8
Joined: 13 Aug 2019, 12:09
Group: Registered users

Postby shafonya » 24 Aug 2019, 01:59

Насчет кривости копирования.
Проверил много образов. Криво копируются не все. Некоторые после копирования работают.

Из тех, что не работают - выпуск Спектрофона. Например 13й.
Записал на дискету, потом с неё снял trd образ.
Образы ДО дискеты и ПОСЛЕ записи на дискету приложил.

Посмотрю еще хексовый дифф образов. Может чего насмотрю...
Attachments
TEST.TRD
Образ снятый с дискеты после кривого копирования. Он не работает, как и физическая дискета, с которой этот образ сняли
(640 KB) Downloaded 57 times
SP13.TRD
Это файл ДО копирования. Он работает.
(640 KB) Downloaded 52 times
shafonya
 
Posts: 8
Joined: 13 Aug 2019, 12:09
Group: Registered users

Postby savelij » 24 Aug 2019, 10:34

shafonya wrote:Из тех, что не работают - выпуск Спектрофона. Например 13й.

Посмотрел бинарный дифф. Номера секторов в каталоге уже не совпадает. Возможно это часть защиты от копирования. И в области данных тоже есть не совпадения. У него наверно специально испорчен каталог чтобы скопировать было нельзя. Потому и копирует шнягу. Про автозапуск сейчас буду смотреть.
savelij
 
Posts: 549
Joined: 10 Jun 2008, 17:35
Group: Registered users

Postby savelij » 24 Aug 2019, 11:26



Объясняю что делал. Монтирую на D трд образ. По кнопке S сброс в тырдос. На А ничего нет и ничего не стартует. Переключаю реальный дисковод на D, сброс по кнопке S в тырдос. Автостарт срабатывает потому что на D смонтирован трд образ. Возвращаю реальный дисковод на А. По кнопке S сброс и автостарта опять нет, на А ничего нет.
Пысы: рамдиск не привязан не на какую букву, он просто есть. Если реальный дисковод совпадает с виртуальным, то начинается работа с рамдиском. Если на виртуальной букве что то смонтированно, то работает с примонтированным образом. У примонтированного образа приоритет выше. Если отмонтировать то опять будет работа с рамдиском.
savelij
 
Posts: 549
Joined: 10 Jun 2008, 17:35
Group: Registered users

Next

Return to Пентева - софт и железо

Who is online

Users browsing this forum: No registered users and 4 guests