Самостостоятельно собираю ZX Evolution. Есть вопросы.

ZX evolution software and hardware

Postby Misk » 22 Sep 2022, 22:54

Собираю самостоятельно ZX Evolution. Спаял, прошил, нахожусь на этапе тестирования. Выводит изображение на монитор, тест памяти проходит, есть звук AY и бипер, читает SD карту, клавиатура, мышь работает, COM порт и USB-COM тоже работает. С SD карты программы запускаются.Spectruma раньше не было и как им пользоваться толком не знаю.

Сейчас непонятно несколько моментов и поэтому прошу помощи знающих людей.
1. Возникли проблемы с приобретением КР1818ВГ93.
Есть ли возможность заменить КР1818ВГ93 на MB8877? Какие могут быть проблемы, нужно ли что-то переделывать? Кто-нибудь уже делал так?
2. Какой жесткий диск лучше подключать? С какими не работает/работает?
3. Звук проверял на наушниках 33 Ом. Бипер слышно только в одном канале, AY играет, но качество меня смущает. Это из-за наушников? Как проверить нормально ли выдает сигналы чим AY? (приборы все есть).
Misk
 
Posts: 5
Joined: 28 Aug 2022, 09:25
Group: Registered users

Postby admin » 25 Sep 2022, 22:13

Misk wrote:1. Возникли проблемы с приобретением КР1818ВГ93.
Есть ли возможность заменить КР1818ВГ93 на MB8877? Какие могут быть проблемы, нужно ли что-то переделывать? Кто-нибудь уже делал так?
2. Какой жесткий диск лучше подключать? С какими не работает/работает?
3. Звук проверял на наушниках 33 Ом. Бипер слышно только в одном канале, AY играет, но качество меня смущает. Это из-за наушников? Как проверить нормально ли выдает сигналы чим AY? (приборы все есть).

1. Можно заменить, но не нужно 12в на MB8877
2. Любой, у меня стоит на 40Гб
3. Есть гдето тест чипа, посмотрите на vtrdos
admin
Site Admin
 
Posts: 75
Joined: 16 Dec 2009, 02:24
Group: Administrators

Postby lvd » 26 Sep 2022, 16:53

Misk wrote:3. Звук проверял на наушниках 33 Ом. Бипер слышно только в одном канале, AY играет, но качество меня смущает. Это из-за наушников? Как проверить нормально ли выдает сигналы чим AY? (приборы все есть).

Для начала проверить питание ~8 вольт операционников в звуковом тракте. Проверить питание аигрека.
Многого нет здесь: http://lvd.nedopc.com
Image
User avatar
lvd
 
Posts: 1786
Joined: 07 Apr 2007, 22:28
Group: Registered users

Postby LinuxoEd » 02 Oct 2022, 20:57

Тоже, собрал, всё работает, акромя выхода на ленту... кассету читает, но "tape out" - пустой.... 4069 - уже менял... при смене прошивки на старую (0.55b) что-то меняется, такое ощущение, что 133-я нога "альтеры" - поднимается до 2,5 вольт, но ленту ещё не щупал..
LinuxoEd
 
Posts: 6
Joined: 11 Sep 2022, 21:55
Group: Registered users

Postby LinuxoEd » 02 Oct 2022, 21:02

А может, я не там ищу? по схеме, вроде от "BEEP"а должно идтить.... подскажите, кто в курсе...
LinuxoEd
 
Posts: 6
Joined: 11 Sep 2022, 21:55
Group: Registered users

Postby lvd » 03 Oct 2022, 19:38

Какая-то распальцовка есть, переключающая вывод BEEP-tapeout. В доках наверное написано какая.
Многого нет здесь: http://lvd.nedopc.com
Image
User avatar
lvd
 
Posts: 1786
Joined: 07 Apr 2007, 22:28
Group: Registered users

Postby DimkaM » 04 Oct 2022, 08:28

Numlock вроде переключает tape/beep
ZX-Evo rev B, ZX-Evo rev C, ZXNetUsb rev A, ZXNetUsb rev С
http://nedoos.ru/ http://ti6.zxevo.ru/
DimkaM
 
Posts: 1387
Joined: 24 Mar 2010, 13:42
Location: джунгли Амазонки
Group: Registered users

Postby Misk » 05 Dec 2022, 09:39

Подключил активные колонки, звук вроде наладился.
Часы и батарейка работают нормально (часы идут точно), ATX блок питания включается/выключается нормально,
все стартует, монитор показывает неплохо, VGA режимы все переключается.
Сейчас занимаюсь доработкой дисковода и жесткого диска.
После прошивки получилась такая конфигурация (плата рев.С):
EVO Reset Service v0.59.07
ZX-Evolution 4096 Kb
Baseconf: ZXEvo 4M 25.12.2021
AVR Boot: ZXEvoAVRBoot 23.01.2012


TAP файлы запускаются, работают, TRD образы монтируются, запускаются.

Проблема возникла с запуском программ $C, включая NedoOS.
Запускаю с SD карты размером 8Gb.
При попытки запустить такие исполняемые файлы компьютер намертво зависает, черный экран.
Никаких сообщений не выводится, помогает только полный сброс.
Возможно проблема в прошивке.
На какой прошивке (версия всех частей) должна запускаться NedoOS?
Есть ли какой-то тест для проверки составных частей компьютера (типа CheckIt для DOS)?
В конфигурации Test&Service тесты проходили, работало вроде все более-менее.
Misk
 
Posts: 5
Joined: 28 Aug 2022, 09:25
Group: Registered users

Postby lvd » 05 Dec 2022, 20:37

Я бы сначала проверил сд-карту. Что читается с нее то же, что записали.
Многого нет здесь: http://lvd.nedopc.com
Image
User avatar
lvd
 
Posts: 1786
Joined: 07 Apr 2007, 22:28
Group: Registered users

Postby Misk » 18 Dec 2022, 18:47

Продолжаю тестировать и разбираться.
Основная проблема - не запускается hoteba в Baseconf. Других глюков в Baseconf пока незаметил.
Также не запускается NedoOS (по причине незапускания hoteba).
При попытки запустить hoteba файл компьютер намертво зависает. Черный экран. Помогает только hard reset.
Других глюков пока не заметил.
Перешил на двойную конфигурацию. Проверил память Universal Memory Tester v2.3 из под TSconfig. Ошибок нет.
Проверил прошивку ROM. CRC совпадают.
WC в TSconf запускается и нормально работает. Программы в TSConf запускаются.
Карта памяти исправна. Размер 8GB. Форматировал в FAT32. Пробовал создавать раздел на 4GB и форматировать в FAT16.
Результата не дало.
Сейчас такая конфигурация:
EVO Reset Service v0.58.16
ZX-Evolution 4096 Kb
Baseconf: ZXEvoTS&BASE 28.04.2021 beta
AVR Boot: ZXEvoAVRBoot 23.01.2012
Прошу помощи, в чем может быть проблема незапуска hoteba файлов (и NedoOS) в Baseconf?
Misk
 
Posts: 5
Joined: 28 Aug 2022, 09:25
Group: Registered users

Next

Return to Пентева - софт и железо

Who is online

Users browsing this forum: No registered users and 0 guests